Error Message

Could not find invoice X

Cause

This happens when the connector is trying to find an invoice to check if was paid in QuickBooks Online but the invoice cannot be found. The link between the ServiceBox invoice and the QuickBooks Online invoice has been broken likely because the invoice was deleted from QuickBooks Online.


Resolution

To resolve this, you will have to unlink the invoice in ServiceBox and re-run the sync to re-create it in QuickBooks Online